Monthly Archives: October 2012

OEM like branding in Windows 7

I needed to figure out a simple way to set the default background image. I didn’t want to force the background image, I didn’t want to apply a GPO, and I wasn’t having much luck editing the default user hive. I happen to stumble onto this solution by chance, really. So into regedit we go for this.

The location I am looking for is:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Themes]

You may need to add keys, but in general you want the below keys to be set. I set DesktopBackground, but excluded it in this example because it contained a path I didn’t want to post. This is just a hex string that contains the full path to a file using the oobe folder is recommended. The oobe folder may not exist on your system, so go ahead and create it if needed.

“Drop Shadow”=”FALSE”
“Flat Menus”=”FALSE”
“SetupVersion”=”10”
“InstallTheme”=”C:\\Windows\\resources\\Themes\\aero.theme”
“InstallVisualStyle”=”%ResourceDir%\\themes\\Aero\\Aero.msstyles”
“DesktopBackground”=hex(2):
“BrandIcon”=”C:\\Windows\\System32\\oobe\\info\\logo.bmp”
“NoThemeInstall”=dword:00000000
“ThemeName”=”Theme Name”
“WindowColor”=”Slate”

Using this plus other OOBE branding, I was able to make a bat file which upon running completely sets up branding on the System Information panel, theme and default background.

Read More

Execution ‘‘ cannot be found (rsExecutionNotFound)

While configuring Reporting Services on a server running Windows 2008 R2, I came across this issue. After some searching I found out Microsoft has a kb article about this (http://support.microsoft.com/kb/972328), however it mentions only applying to MSSQL 2005. Well the Server I had had MSSQL 2008 R2, as well as SharePoint 2010 and Exchange 2010. It seems that this fix also still works. So if you are confused as to why this is happening and think the article doesn’t apply to you, give it a shot anyways.

Read More

Highslide for Wordpress Plugin